Cisco 881G UMTS Konfiguration

Um mit einem Cisco 881G über UMTS ins Internet zu kommen, muss die UMTS Schnittstelle des Routers konfiguriert werden. Leider ist die Konfiguration der UMTS Schnittstelle (Cellular0) nicht mit der Weboberfläche CP Express möglich. Daher erfolgt die Konfiguration der UMTS Schnittstelle über das Command Line Interface (CLI).

Als Erstes wird im privilegierten Modus ein Wählprofil erstellt (hier für T-Mobile):

cellular 0 gsm profile create 1 internet.t-mobile.de ipv4 chap t-mobile tm

Danach werden die restlichen Einstellungen im Konfigurationsmodus durchgeführt:
Dialer-Script für den Verbindungsaufbau:

chat-script gsm "" "ATDT*99***1#" TIMEOUT 60 "CONNECT"

Konfiguration der 3G Schnittstelle:

interface Cellular0
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer in-band
 dialer string gsm
 dialer-group 1
 dialer idle-timeout 120
 async mode interactive
 ppp chap hostname t-mobile
 ppp chap password 0 tm
 ppp ipcp dns request

Asynchrone Leitung für die Verbindung konfigurieren:

line 3
 exec-timeout 0 0
 script dialer gsm
 modem InOut
 no exec
!
interface Vlan1
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat inside
 ip virtual-reassembly
 ip route-cache flow
 ip tcp adjust-mss 1452

Default Route setzen:

ip route 0.0.0.0 0.0.0.0 Cellular 0
ip name-server 208.67.222.222
ip domain-lookup

Access-list für NAT:

access-list 2 permit 10.10.10.0 0.0.0.7
ip nat inside source list 2 interface Cellular0 overload

Access-list für das DDR (Dial on demand routing)

access-list 1 permit 10.10.10.0 0.0.0.7
dialer-list 1 protocol ip list 1

Wenn jetzt ein Ping an eine externe IP gesendet wird, wird die Schnittstelle Cellular0 aktiviert und die Verbindung baut sich auf. Die Internetverbindung steht und kann verwendet werden.

Hinweis: Für andere Provider müssen die Einstellungen geändert werden. Ebenso sollten die lokalen IP Adressen angepasst werden.

4 Kommentare

Schreibe einen Kommentar

You have to agree to the comment policy.

This Blog will give regular Commentators DoFollow Status. Implemented from IT Blögg