Cisco Switch Makro (Switch Macro)

Ein nicht sehr bekanntes Feature von Cisco ist das Makro. Diese Funktion ist aber sehr hilfreich (habe ich HIER schon mal angesprochen) und kann die Konfiguration der Switche und Switchports sehr erleichtern. Ein Makro kann global oder per Interface angewandt werden. Somit können Makros für fast alles verwendet werden.
Ein Makro besteht aus einer Reihe von Befehlen, die beim Aufruf ausgeführt, bzw. eingetragen werden. Es ist auch möglich, mit Variablen zu arbeiten. Die Werte der Variablen werden beim Aufruf des Makros mit übergeben.
Makro erstellen:
#Makro erstellen mit dem Namen ACCESS
macro name ACCESS

#$port ist die eine Variable um den Port zu wählen, der Befehl default setzt den Port auf die Grundeinstellungen zurück
default interface FastEthernet$port
#Wieder die $port Variable, um den Port zu wählen, $vlan, um das Access VLAN zu setzen
int gi$port
description AccessPort
switchport access vlan $vlan
switchport mode access
spanning-tree bpduguard enable
#Jedes Makro wird mit @ beendet
@

Um jetzt einen ACCESS Port zu konfigurieren, muss nur noch folgender Befehl ausgeführt werden:
macro global apply [Name des Makros] [Definition der Variablen]

Makro ACCESS anwenden
macro global apply ACCESS $port 12 $vlan 10

Dieses hier war als Beispiel ein globales Makro, welches den Port 10 auf VLAN 10 konfiguriert.
Makros können auch Portweise angewandt werden, zum Beispiel für eine Port Range.

Hier mal zwei Beispiel Makros, das Erste um den Port (die Ports) zurückzusetzen:
macro name default
No macro description
description default no config
switchport mode access
no switchport access vlan
no switchport port-security
no switchport port-security violation
no switchport port-security maximum 2
no switchport port-security mac-address sticky
no switchport port-security aging time 1
no switchport port-security aging type inactivity
no ip arp inspection limit rate 10
no storm-control broadcast level pps 50
no storm-control multicast level pps 100
no storm-control action shutdown
no storm-control action trap
no spanning-tree portfast
no spanning-tree bpduguard enable
no ip dhcp snooping limit rate 20
no ip verify source
no ip dhcp snooping trust
no ip arp inspection trust
shutdown
@

Damit werden alle vorhandenen Einstellungen von dem Port entfernt.

Das zweite Makro konfiguriert den Port als Access Port:
macro name ACCESS
# member of ACCESS vlan
description user_$vlan $descr
switchport access vlan $vlan
# no tagged interface, no trunk
switchport mode access
# storm control, broadcast 50, multicast 100
storm-control broadcast level pps 50
storm-control multicast level pps 100
storm-control action shutdown
storm-control action trap
# Enable port security limiting port to a 2 MAC
# addressess -- One for desktop on data vlan and
# one for phone on voice vlan
switchport port-security
switchport port-security violation protect
switchport port-security maximum 2
switchport port-security aging time 1
switchport port-security aging type inactivity
# spanning tree enabled, incl. BPDU-Guard
spanning-tree portfast
spanning-tree bpduguard enable
no shutdown
@

Die Ausführung ist ähnlich dem des globalen Makros, allerdings muss hier zuerst zu dem Port gewechselt werden:
Für eine Port Gruppe sieht das dann so aus :
interface range FastEthernet0/1 - 10
marcro apply default
macro apply ACCESS $vlan 10 $descr AccessPort

Schon sind die Ports 1 – 10 fertig und identisch konfiguriert.

Hinweis: Makros können für alle möglichen Konfigurationen verwendet werden. Dies gilt nicht nur für Switche. Router der 800er Serie beherrschen Makro Befehle ebenso und können damit konfiguriert werden – zum Beispiel das ändern der WAN IP inklusive Default Route (dazu später mehr)

2 Kommentare

  • Frank

    Auf meinem 2950-24 gibts das macro-Kommando leider nicht. Auch die Simulation NetSimK kennt nichts dergleichen. Schade. Zumal die Macros sogar im Handbuch beschrieben sind.

Schreibe einen Kommentar

You have to agree to the comment policy.

This Blog will give regular Commentators DoFollow Status. Implemented from IT Blögg